Telemedicine Not Working

Incident Report for Cerbo | Status

Resolved

This incident has been resolved.
Posted Mar 25, 2025 - 07:00 PDT

Identified

We have identified an issue with a recent release that has affected our Telemedicine service. We are rolling back this release and this feature should be working shortly.
Posted Mar 25, 2025 - 06:59 PDT