Slow performance in Cerbo
Incident Report for Cerbo | Status
Resolved
This incident has been resolved
Posted Nov 25, 2024 - 11:29 PST
Update
We are continuing to investigate this issue. Clearing your browser's cache should speed up your system in the meantime
Posted Nov 25, 2024 - 10:08 PST
Investigating
Some clients are reporting slow performance in Cerbo. We are currently investigating this issue. Clearing your browser's cache should speed up your system in the meantime
Posted Nov 25, 2024 - 09:26 PST